Задать вопрос
10 июля, 13:35

Даны две строки. Вычеркнуть из строки A символы, не встречающиеся в строке B.

Помогите написать программу для delphi или pascal.

+4
Ответы (1)
  1. 10 июля, 16:16
    0
    Var a, b:string; i:integer;

    begin

    write ('a: ') ;

    readln (a) ;

    write ('b: ') ;

    readln (b) ;

    for i:=length (a) downto 1 do

    if pos (a[i], b) = 0 then delete (a, i, 1) ;

    writeln (a) ;

    end.

    Пример:

    a: primer

    b: write

    rier
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны две строки. Вычеркнуть из строки A символы, не встречающиеся в строке B. Помогите написать программу для delphi или pascal. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки. "выбрать из нее символы кратные 4 и напечатать их (т. е.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)