Задать вопрос
4 марта, 18:45

Составить программу на языке Pascal. Программа заполняет одномерный массив из 20 элементов случайными числами от 1 до 100 и выводит на экран

5-ый и 7-ой элементы массива.

+3
Ответы (1)
  1. 4 марта, 20:07
    0
    Var A:array[1 ... 20] of byte;

    i:integer;

    Begin

    Write ('Массив: ') ;

    For i: = 1 to 20 do

    Begin

    A[i]:=random (100) + 1;

    Write (A[i],' ')

    End;

    WriteLn;

    WriteLn ('A[5] = ', A[5]) ;

    WriteLn ('A[7] = ', A[7]) ;

    End.

    Без вывода самого массива:

    Var

    A:array[1 ... 20] of byte;

    i:integer;

    Begin

    For i: = 1 to 20 do

    A[i]:=random (100) + 1;

    WriteLn ('A[5] = ', A[5]) ;

    WriteLn ('A[7] = ', A[7]) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на языке Pascal. Программа заполняет одномерный массив из 20 элементов случайными числами от 1 до 100 и выводит на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)