Задать вопрос
26 апреля, 13:38

Составить программу.

Введите 7 чисел. Найти сумму больше 3 и произведение меньше 3.

+2
Ответы (1)
  1. 26 апреля, 15:05
    0
    Program semchisel;

    Var a, i, sum, proiz:integer;

    Begin

    proiz:=1; sum:=0;

    for i:=1 to 7 do

    begin

    read (a) ;

    if (a<3) then proiz:=proiz*a;

    if (a>3) then sum:=sum+a;

    end;

    Writeln ('proiz=', proiz, ' ', 'sum=', sum) ;

    Readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу. Введите 7 чисел. Найти сумму больше 3 и произведение меньше 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программы Введите несколько чисел. Найдите произведение чисел меньших 7. Введите несколько чисел. Найдите количество двузначных чисел. Введите несколько чисел.
Ответы (1)
Написать в тетради программу на Pascal: Спросить у пользователя три числа. Вывести сумму чисел, среднее значение. Пример: Введите а: 5 Введите b:4 Введите c:3 Сумма: 12 Среднее: 6
Ответы (1)
Программа не запускается исправьте программу program lab1; Var x, a, nx:integer; y:real; begin write ('Введите x: ') ; read (x) ; write ('Введите a: ') ; read (a) ; write ('Введите nx: ') ; read (nx) ; If a
Ответы (1)
Program Series17; var a, B, N, i:integer; bol:boolean; begin i:=0; n:=0; bol:=true; Writeln ('Введите число B') ; readln (B) ; Writeln ('Введите число N') ; Readln (N) ; Writeln ('Введите ', N,' целых чисел.
Ответы (2)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)