Задать вопрос
17 июля, 20:04

1) Вывести числа кратные (11) от 10 до 100 в Turbo pascal

2) С клавиатуры вводятся числа и последовательно перемножаются. Найти кол-во введённых чисел, когда их произведение превысит 1000. Прошу помощи.

+5
Ответы (1)
  1. 17 июля, 23:59
    0
    1.

    var i:integer;

    begin

    for i:=10 to 100 do

    if i mod 11 = 0 then write (i,' ') ;

    writeln;

    end.

    Результат:

    11 22 33 44 55 66 77 88 99

    2.

    var a, k, p:integer;

    begin

    readln (a) ;

    p:=1; k:=1;

    while p<=1000 do

    begin

    p:=p*a;

    k:=k+1;

    readln (a) ;

    end;

    writeln ('k = ', k,' p = ', p) ;

    end.

    Пример:

    5

    8

    4

    9

    7

    k = 5 p = 1440
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Вывести числа кратные (11) от 10 до 100 в Turbo pascal 2) С клавиатуры вводятся числа и последовательно перемножаются. Найти кол-во ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
С клавиатуры вводятся 20 чисел. Найти произведение чисел кратных 5. Найти количество неотрицательных чисел. Решить задачу эту задачу надо в Turbo Pascal, методом repeat until или while if
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)