Задать вопрос
27 июля, 12:31

Даны N вещественных чисел. Найти среднее арифметическое отрицательных чисел

+1
Ответы (1)
  1. 27 июля, 15:09
    0
    Program n1;

    var n, i, k: integer;

    sum, a: real;

    begin

    sum:=0;

    k:=0;

    write ('n=') ;

    readln (n) ;

    for i:=1 to n do

    begin

    readln (a) ;

    if a<0 then begin

    sum:=sum+a;

    k:=k+1;

    end;

    end;

    writeln (sum/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны N вещественных чисел. Найти среднее арифметическое отрицательных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
Дана последовательность вещественных чисел а. Найти среднее арифметическое не отрицательных членов этой последовательности.
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)
Линейные алгоритмы. 1. Даны три действительных положительных числа. Найти среднее геометрическое и среднее арифметическое этих чисел. Условный оператор if. 2. Заданы два числа х, у. Меньшее из двух значений заменить на 0.
Ответы (1)