Задать вопрос
6 сентября, 12:29

Нужна помощь по написанию программ!

Задача 1.

Радиус окружности 5 метров.

Вычислить длину и площадь окружности.

радиус окружности R = (5) см

длинна окружности L = () см

площадь круга S = () см кв

Задача 2

Вычислить площадь кольца, внутренний радиус которого равен 20, а внешний числу r.

Задача 3

Вычислить стоимость покупки, состоящей из нескольких тетрадей и такого же количества обложек ним.

Вычисление стоимости покупки

Введи исходные данные:

Цена тетрадей; цена обложек; количество комплектов; количество карандашей; стоимость покупки.

+2
Ответы (1)
  1. 6 сентября, 16:27
    0
    1.

    Const R=5;

    Var L, S:real;

    Begin

    L:=2*Pi*R;

    S:=Pi*sqr (R) ;

    writeln ('Радиус окружности R = ', R, ' см') ;

    writeln ('Длина окружности L = ', L:4:2, ' см') ;

    writeln ('Площадь круга S = ', S:4:2, ' см кв.') ;

    End.

    2.

    Const r1=20;

    Var S1, S2, S, r:real;

    Begin

    writeln ('Введите внешний радиус') ;

    readln (r) ;

    S1:=Pi*sqr (r1) ;

    S2:=Pi*sqr (r) ;

    S:=S2-S1;

    writeln ('Площадь кольца = ', S:4:2) ;

    End.

    3.

    Var tet, ob, col, kar, ck, sum: real;

    Begin

    writeln ('Введите цену 1 тетради') ;

    readln (tet) ;

    writeln ('Введите цену 1 обложки') ;

    readln (ob) ;

    writeln ('Введите количество комплектов') ;

    readln (col) ;

    writeln ('Введите цену 1 карандаша') ;

    readln (kar) ;

    writeln ('Введите количество карандашей') ;

    readln (ck) ;

    sum: = (tet+ob) * col+kar*ck;

    writeln ('Стоимость покупки = ', sum) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужна помощь по написанию программ! Задача 1. Радиус окружности 5 метров. Вычислить длину и площадь окружности. радиус окружности R = (5) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запишите оператор для: 1) Вычисления средних арифметических x1 и x2 2) уменьшения на единицу значения переменной k 3) Увеличения на единицу значения переменной i 4) вычисления стоимости покупки, состоящей из нескольких тетрадей, нескольких ручек и
Ответы (2)
Запишите раздел описания переменных, необохимых ля вычисления а) значения фукции y=x2 б) площади прямоугольника в) стоимости покупки, состоящей из нескольких тетрадей и такого же количества обложек г) стоимости покупки, состойщей из нескольких
Ответы (1)
Напишите программы для следующих задач, организуя экран пользователя по предложенному варианту. Задача 1:Написать программу вычисления площади поверхности параллелепипеда. S=2 * (A*B+B*C+C*A) Введите данные А=9, В=7.
Ответы (1)
Вычисление стоимости покупки. Введите исходные данные: цена тетрадей (руб) ?2.75 цена обложки (руб) ? 0.5 каличество комплектов (шт) ? 7 стоимость покупки: 22.75
Ответы (1)
Написать программу на языке Pascal вычисления стоимости покупки, состоящей из нескольких тетрадей, нескольких ручек и нескольких карандашей.
Ответы (1)