Задать вопрос
26 октября, 11:27

Помогите! Нужно написать программы на Pascal + блок-схемы.

С клавиатуры последовательно вводится n-целых чисел:

1) Сколько чисел отличаются от первого на величину а?

2) Для всех чисел, кроме 1 и последнего, определите, сколько из них больше своих соседей? (слева и справа)

3) Вывести числа, которые делятся на 3, но не делятся на 5.

+2
Ответы (1)
  1. 26 октября, 14:19
    0
    Const

    n = 13;

    Var

    a, i, C, k:integer;

    M:array[1 ... N] of integer;

    Begin

    k:=0;

    Write ('a = ') ;

    ReadLn (a) ;

    WriteLn ('Введите целые числа') ;

    For i: = 1 to n do

    Read (M[i]) ;

    For i: = 2 to n do

    if M[i]-a = M[1] then k:=k+1;

    WriteLn ('1: k = ', k) ;

    k:=0;

    For i: = 2 to n-1 do

    if (M[i-1]M[i+1]) then k:=k+1;

    WriteLn ('2: k = ', k) ;

    Write ('3: ') ;

    For i: = 1 to n do

    if (M[i] mod 3 = 0) and (M[i] mod 5 0) then Write (M[i],' ')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите! Нужно написать программы на Pascal + блок-схемы. С клавиатуры последовательно вводится n-целых чисел: 1) Сколько чисел отличаются ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде блок-схемы или на языке программирования Pascal) 1. С клавиатуры вводятся три целых числа.
Ответы (2)