Задать вопрос
19 марта, 05:37

Напишите программу паскаль: С клавиатуры вводится число от 0 до 1000 включительно. Каждая цифра не превосходит 6. Найти сумму промежуточных значений между наибольшей и наименьшей цифрами в числе?

+4
Ответы (1)
  1. 19 марта, 08:12
    0
    Попробуй, может сработает)

    program num32; var

    nums, i, min, max, a, i2, i3, sum: integer; begin

    min : = 7;

    max : = 0;

    sum : = 0;

    readln (nums) ;

    while nums 0 do

    begin

    if (((nums mod 10) > max)) then begin

    max : = nums mod 10;

    end;

    if (((nums mod 10) < min)) then begin

    min : = nums mod 10;

    end;

    nums : = nums div 10;

    end;

    if (min > max) then begin

    for i2 : = max to min do

    sum : = sum + i2;

    end;

    if (max > min) then begin

    for i2 : = min to max do

    sum : = sum + i2;

    end;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу паскаль: С клавиатуры вводится число от 0 до 1000 включительно. Каждая цифра не превосходит 6. Найти сумму промежуточных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)