Задать вопрос
12 марта, 10:35

Напишите программу на языке Паскаль! На экран вводится два пятизначных числа. Найти среднее арифметическое всех четных цифр в наименьшем числе.

+3
Ответы (1)
  1. 12 марта, 13:12
    0
    Var

    a, b, n: integer;

    sr: real;

    begin

    sr : = 0;

    n : = 0;

    read (a, b) ;

    if (a > b) then a : = b;

    while a > 0 do

    begin

    if ((a mod 10) mod 2 = 0) then begin

    sr : = sr + a mod 10;

    n : = n + 1;

    end;

    a : = a div 10;

    end;

    write (sr / n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке Паскаль! На экран вводится два пятизначных числа. Найти среднее арифметическое всех четных цифр в наименьшем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На экран вводится два пятизначных числа. Найти среднее арифметическое всех четных цифр в наименьшем из чисел
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Напишите программу на языке Паскаль! С клавиатуры вводится три четырёх значных числа. Найти сумму нечётных цифр в наименьшем числе.
Ответы (1)