Задать вопрос
18 июля, 05:35

Найти сумму квадратов четных и произведений кубов не четных чисел, первых двух десятков

+2
Ответы (1)
  1. 18 июля, 07:40
    0
    Var

    s1, i:integer;

    ir, s2:real;

    begin

    s2:=1;

    for i:=1 to 20 do

    begin;

    ir:=i;

    if i mod 2=0 then s1+=sqr (i) else s2*=power (ir, 3) ;

    end;

    writeln ('Cумма квадратов чётных=', s1) ;

    writeln ('Произведение кубов нечётных=', s2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму квадратов четных и произведений кубов не четных чисел, первых двух десятков ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)