Задать вопрос
14 февраля, 03:16

Написать программу поиска элемента массива, равный заданному числу 17, используя поиск с барьером.

Решить на PascalABC

Оформить в виде процедуры.

+2
Ответы (1)
  1. 14 февраля, 04:45
    0
    Const n=10;

    type ar=array[1 ... n+1] of integer;

    var

    a:ar; i, p:integer;

    procedure pr (var a:ar; p:integer; var k:integer) ;

    begin

    k:=1;

    while a[k]p do k:=k+1;

    end;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (31) ;

    write (a[i]:4) ;

    end;

    writeln;

    p:=17;

    a[n+1]:=p;

    pr (a, p, i) ;

    if i
    then writeln ('Значение 17 найдено, номер элемента = ', i)

    else writeln ('Значения 17 в массиве нет') ;

    end.

    Пример:

    Массив A:

    14 5 7 17 25 15 28 0 24 0

    Значение 17 найдено, номер элемента = 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу поиска элемента массива, равный заданному числу 17, используя поиск с барьером. Решить на PascalABC Оформить в виде ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Написать программу поиска номера элемента массива, принадлежащего заданному промежутку [1, 5], используя линейный поиск. Решить на Pascal ABC.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)