Задать вопрос
20 января, 09:41

Написать программу поиска номера элемента массива, принадлежащего заданному промежутку [1, 5], используя линейный поиск. Решить на Pascal ABC.

Пример: Линейный поиск элементов массива:

procedure poisk (z:omas; x:integer) ;

var i, p:byte;

begin

for i:=1 to n do

begin

if z[i]=x then p:=i;

end;

end;

+2
Ответы (1)
  1. 20 января, 11:13
    0
    Const n = 5;

    var

    i, p, x:byte;

    z: array[1 ... n] of byte;

    begin

    readln (x) ;

    for i:=1 to n do

    begin

    readln (z[i]) ;

    if z[i]=x then p:=i;

    end;

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу поиска номера элемента массива, принадлежащего заданному промежутку [1, 5], используя линейный поиск. Решить на Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы