Задать вопрос
31 декабря, 06:30

Обработка двумерных массивов.

Алгоритм вычисления среднего значения массива, пример программы

+2
Ответы (1)
  1. 31 декабря, 08:35
    0
    Пример, ненужное уберешь

    const

    handsfree = true;

    var

    a: array[1 ... 100, 1 ... 100] of real;

    max, min: real;

    sum, product: real;

    i, j, m, n, k: integer;

    begin

    {ввод матрицы}

    if handsfree then begin

    n : = random (20) + 2;

    m : = random (20) + 2;

    end

    else begin

    write ('n, m = ') ;

    readln (n, m) ;

    end;

    writeln ('Данные матрицы:') ;

    for i : = 1 to m do

    begin

    for j : = 1 to n do

    if handsfree then begin

    a[i, j] : = random (100) - 50;

    write (a[i, j]:4, ' ')

    end

    else

    read (a[i, j]) ;

    writeln;

    end;

    {минимумы и максимумы}

    max : = a[1, 1];

    min : = a[1, 1];

    for i : = 1 to m do

    for j : = 1 to n do

    begin

    if max < a[i, j] then max : = a[i, j];

    if min > a[i, j] then min : = a[i, j];

    end;

    writeln ('max = ', max) ;

    writeln ('min = ', min) ;

    {сумма, произведение, пр. агригаты}

    sum : = 0;

    product : = 1;

    for i : = 1 to m do

    for j : = 1 to n do

    if a[i, j] 0 then {если нужен фильтр}

    begin

    sum : = sum + a[i, j];

    product : = product * a[i, j];

    k : = k + 1;

    end;

    writeln ('sum = ', sum) ;

    writeln ('product = ', product) ;

    writeln ('average = ', sum / (n * m)) ;

    writeln ('average (selected) = ', sum / k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Обработка двумерных массивов. Алгоритм вычисления среднего значения массива, пример программы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Отметьте верное. 1) При форматировании текстового документа происходит ... А) обработка, связанная с изменением формы информации, но не изменяющая ее содержания Б) обработка, связанная с получением нового содержания, новой информации В) обработка
Ответы (1)
Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле: Вычислить сумму положительных элементов матрицы А (10 х10), расположенных над главной диагональю.
Ответы (1)
Обработка Информации. Обработка Информации бывает двух типов: 1) обработка, связанная с получением нового содержания, новой информации; 2) обработка, связанная с изменением формы информации, но не изменяющая её содержания.
Ответы (1)