Задать вопрос
30 ноября, 11:44

Вычислить количество всех трехзначных чисел сумма цифр которых равна 12

+1
Ответы (2)
  1. 30 ноября, 13:39
    0
    Всего: 66

    Паскаль:

    Var i, n : Integer;

    Begin

    n:=0;

    For i:=100 to 999 do

    If i div 100 + i div 10 mod 10 + i mod 10 = 12 then

    Begin

    Inc (n) ;

    Writeln (i) ;

    end;

    Writeln ('Всего: ', n) ;

    end.
  2. 30 ноября, 15:05
    0
    Всего: 66.

    Java

    int counter = 0;

    for (int i = 1; i < 10; i++)

    for (int j = 0; j < 10; j++)

    for (int k = 0; k < 10; k++)

    if (i+j+k==12) { System. out. println (String. valueOf (i) + String. valueOf (j) + String. valueOf (k)) ;

    counter++;

    }

    System. out. println ("Итого: " + counter + " чисел") ;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить количество всех трехзначных чисел сумма цифр которых равна 12 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
С клавиатуры вводятся два трехзначных числа. Выяснить, образуют ли сумма цифр сотен, сумма цифр десятков, сумма цифр единиц введенных чисел убывающую последовательность.
Ответы (1)
Автомат получает на вход два трехзначных числа. По этим числам строится новое число по следующим правилам. Вычисляются три числа - сумма старших разрядов заданных трехзначных чисел, сумма средних разрядов этих чисел, сумма младших разрядов.
Ответы (1)
Среди всех трёхзначных положительных чисел найти количество тех, у которых сумма цифр является чётным числом. На экран вывести как сами найденные числа, так и их количество.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)