Задать вопрос
18 ноября, 01:08

Дана последовательность произвольных чисел. найти количество чисел, сумма которых не превышает заданное число. АВС паскаль

+4
Ответы (1)
  1. 18 ноября, 02:59
    0
    Var sum, n, a, max: integer;

    begin

    write ('введите макс число ') ;

    read (max) ;

    sum:=0; n:=0;

    writeln ('вводите числа') ;

    while (true) do

    begin

    read (a) ;

    if (a+sum) > max then break;

    sum:=sum+a;

    inc (n) ;

    end;

    write ('кол во чисел ', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность произвольных чисел. найти количество чисел, сумма которых не превышает заданное число. АВС паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Cтроки. Паскаль. 1. Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному (символы записываются в обратной последовательности.) 2. Дана символьная строка.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Определить сколько раз последовательность из N произвольных чисел меняет знак. Сохранить в новом файле последовательность одного знака максимальной длины. Паскаль. Не массив
Ответы (1)