Задать вопрос
5 февраля, 05:37

Составить алгоритм на языке Паскаль решения задачи: найти среднюю скорость движения поезда, если Т1 час он двигался со скоростью V1, а Т2 часа - со скоростью V2

+1
Ответы (1)
  1. 5 февраля, 06:19
    0
    Var t1, v1, t2, v2, s1, s2, s, t, v : real;

    begin

    write ('t1 = ') ;

    read (t1) ;

    write ('v1 = ') ;

    read (v1) ;

    write ('t2 = ') ;

    read (t2) ;

    write ('v1 = ') ;

    read (v2) ;

    s1 : = v1 * t1;

    s2 : = v2 * t2;

    s : = s1 + s2;

    t : = t1 + t2;

    v : = s / t;

    write ('Cp. v = ', v) ;

    end.

    Пример работы программы:

    t1 = 2

    v1 = 5

    t2 = 3

    v1 = 10

    Cp. v = 8
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм на языке Паскаль решения задачи: найти среднюю скорость движения поезда, если Т1 час он двигался со скоростью V1, а Т2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Разработайте алгоритм решения Разработайте алгоритм решения задачи, запишите его в виде блок-схемы. По полученному алгоритму запишите программу на языке Паскаль. Найдите расстояние между двумя точками с заданными координатами.
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)