Задать вопрос
13 августа, 02:33

На экран вводится последовательность

натуральных чисел, не превышающих 1000. Последовательность заканчивается

числом 0. Количество чисел в последовательности не превышает 100.

Выведите на экран количество чисел в последовательности (не считая 0),

а потом сами числа.

+1
Ответы (1)
  1. 13 августа, 03:54
    0
    Var

    x, k:integer;

    a:array[1 ... 100] of integer;

    begin

    k : = 0;

    read (x) ;

    while x 0 do

    begin

    k : = k + 1;

    a[k] : = x;

    read (x)

    end;

    writeln (k) ;

    for x : = 1 to k do

    write (a[x],' ')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На экран вводится последовательность натуральных чисел, не превышающих 1000. Последовательность заканчивается числом 0. Количество чисел в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)