Задать вопрос
19 мая, 11:08

Напишите программу, решающую любое квадратное уравнение. Паскал

+2
Ответы (1)
  1. 19 мая, 12:36
    0
    Program kv_ur;

    var a, b, c, d, x1, x2, x:real;

    begin

    read (a, b, c) ;

    d: = sqr (b) - 4*a*c;

    if d<0 then write ('нет решений') ;

    if d = 0 then

    begin

    x: = - b / (2*a) ; write ('один корень: ', x:5:2)

    end;

    if d>0 then

    begin

    x1: = (-b+sqrt (d)) / (2*a) ;

    x2: = (-b-sqrt (d)) / (2*a) ;

    write ('два корня: ', 'x1=', x1:5:2,'x2=', x2:5:2)

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, решающую любое квадратное уравнение. Паскал ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы