Задать вопрос
31 августа, 15:06

1. Запишите значение переменной s (по табличке), полученное в результате работы следующей программы:

s : = 8;

for k : = 3 to 8 do

s : = s + 8;

writeln (s) ;

2. Написать программу, которая вычисляет сумму всех двузначных чисел

+4
Ответы (1)
  1. 31 августа, 16:56
    0
    1.

    s=8

    k=3, s=s+8=8+8=16

    k=4, s=16+8=24

    k=5, s=24+8=32

    k=6, s=32+8=40

    k=7, s=40+8=48

    k=8, s=48+8=56

    Ответ: s=56

    2.

    var i, s:integer;

    begin

    s:=0;

    for i:=10 to 99 do s:=s+i;

    writeln ('s = ', s) ;

    end.

    Результат:

    s = 4905
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Запишите значение переменной s (по табличке), полученное в результате работы следующей программы: s : = 8; for k : = 3 to 8 do s : = s + ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Имеется условный оператор:if D10 then writeln ('ура!') else writeln ('плохо ...') ; Какими операторами его можно заменить? Выберите несколько из 4 вариантов ответа: 1) if D=10 then writeln ('ура!') else writeln ('плохо ...
Ответы (1)
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)
1. Что такое файл, каталог, корневой каталог, родительский каталог, текущий каталог, путь, полное имя файла? 2. Что означают символы * и? в имени файла? 3. Алгоритм поиска файлов на МД, реализуемый MS DOS. 4. Виды файлов.
Ответы (1)
Запишите значение переменной y, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования. Var y, i: integer; Begin y : = 0; For i : = 1 to 3 do y : = y + 4*i; Writeln (y) ; End.
Ответы (1)