Задать вопрос
21 марта, 23:21

Дан фрагмент программы (использующий цикл с предусловием) :

K:=0;

While k<10 do begin

K: = k+1;

P:=k*k;

Writeln (p) ;

End

Что выводится на экран в результате выполнения данного фрагмента?

Напишите полный текст программы вычисляющей произведение натуральных чисел от 1 до n значение n программа запрашивает у пользователя

+2
Ответы (1)
  1. 22 марта, 00:47
    0
    1

    4

    9

    16

    25

    36

    49

    64

    81

    100

    (в результате выполнения данного фрагмента выводится это)

    Напишите полный текст программы вычисляющей произведение натуральных чисел от 1 до n значение n программа запрашивает у пользователя

    Я решил через "for". Если надо "While" напиши

    var s, n, i:integer;

    begin

    read (n) ;

    s:=1;

    for i:=1 to n do s:=s*i;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан фрагмент программы (использующий цикл с предусловием) : K:=0; While k ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дан фрагмент программы: For i: = 1 to 10 do begin Writeln ('Hello, world!') End Что выполняет данный фрагмент? 2) дан фрагмент программы: For i: = 1 to 15 do begin Writeln (i) End Что выполняет данный фрагмент?
Ответы (1)
1. Какой тип данных может иметь параметр цикла? 2. В каких случаях при написании программ лучше использовать оператор цикла с предусловием? 3. В каких случаях цикл с предусловием может быть бесконечным? 4.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Дан фрагмент программы: read (a) ; read (b) ; c:=a+b; write (a, b) ; write (c) Упростите его, сократив число операторов ввода и вывода. Дан фрагмент программы: a:=10; b:=a+1: a:=b-a; write (a, b) Какие числа будут выведены на экран компьютера?
Ответы (1)
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)