Задать вопрос
23 октября, 19:54

Дано целое четырехзначное число если первая цифра большечем последняя то увеличте в 2 раза иначе в 10 раз. написать программу в паскаль

+4
Ответы (1)
  1. 23 октября, 22:23
    0
    Var a : integer;

    Begin

    Readln (A) ;

    If (A div 10000 > (A mod 10) then A:=A*2 else A:=A*10;

    Writeln (A) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое четырехзначное число если первая цифра большечем последняя то увеличте в 2 раза иначе в 10 раз. написать программу в паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано целое четырехзначное число N. Если первая цифра числа больше, чем последняя, то увеличить число в 2 раза иначе увеличить число в 10. написать програму (паскаль)
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
2) Вводится четырехзначное число с клавиатуры. Определить цифру тысяч, сотен, десятков и единиц. В окне вывода должно быть так (это пример) Введи четырехзначное число: 1234 цифра тысяч-1 цифра сотен-2 цифра десятков-3 цифра единиц - 4
Ответы (1)