Задать вопрос
13 января, 14:10

Даны натуральные числа n a1 ... an. составьте программу которая вычисляет сумму тех элементов последовательности а1 ... an которые кратны 3 м

+1
Ответы (1)
  1. 13 января, 17:07
    0
    Const n=100;

    var a: array [1 ... n] of integer;

    s, i: integer;

    begin

    s:=0;

    for i:=1 to n do

    { вывод массива на экран }

    begin

    a[i]:=Random (100) ;

    write (a[i],' ') ;

    if (i mod 10 = 0) then writeln () ;

    end;

    { подсчет суммы элементов, кратных 3 }

    for i:=1 to n do

    if (a[i] mod 3 = 0) then s:=s+a[i];

    writeln ('сумма равна ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральные числа n a1 ... an. составьте программу которая вычисляет сумму тех элементов последовательности а1 ... an которые кратны 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Язык - Pascal. даны натуральные числа n, a1, ..., an. Составьте программу, которая вычисляет сумму тех элементов последовательности a1, ..., an, которые нечетны и отрицательны
Ответы (1)
Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)
Язык - Pascal. даны натуральное число n и последовательностьa1, ..., an. Составьте программу, которая находит среднее арифметическое тех элементов последовательности, которые кратны 3 и не кратны 9
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)