Задать вопрос
15 августа, 13:23

Составьте программу в результате выполнения которой выясняется входят ли четные цифры в запись данного трехзначного числа. Для паскаля

+2
Ответы (1)
  1. 15 августа, 17:01
    0
    Var a, a1, a2, a3:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    a1:=a div 100;

    a2:=a div 10 mod 10;

    a3:=a mod 10;

    if (a1 mod 2 = 0) or (a2 mod 2 = 0) or (a3 mod 2 = 0)

    then writeln ('В числе есть четные цифры')

    else writeln ('В числе нет четных цифр') ;

    end.

    Пример:

    a = 519

    В числе нет четных цифр
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу в результате выполнения которой выясняется входят ли четные цифры в запись данного трехзначного числа. Для паскаля ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. (x делится без остатка на 2 и на 3) записать на языке паскаля. 2. (х не делится на 5) записать на языке паскаля. 3. (величина х не кратна 3) записать на языке паскаля.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
В результате выполнения некого оператора переменные получили следующие значения a=3, c=9 укажите правильную запись данного оператора.
Ответы (1)
1) Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обменяются значениями. При этом нельзя использовать дополнительные переменные.
Ответы (1)
Сумма цифр случайного трехзначного числа (Например, число 123 - это и есть цифры трехзначного числа, для общего случая это будет xyz. Обозначает за x - первое число, y - второе число, z - третье число. Результатом будет r=x+y+z)
Ответы (1)