Задать вопрос
31 мая, 12:37

Информатика програмирование составить программу признаки делимости на 3, 5, 9, 10, 11

+4
Ответы (1)
  1. 31 мая, 16:17
    0
    Var

    a:longint;

    begin

    readln (a) ;

    k:=a mod 3;

    If k=0 then writeln ('Число делиться на 3')

    else

    writeln ('Число не делиться на 3') ;

    k:=a mod 5;

    If k=0 then writeln ('Число делиться на 5')

    else

    writeln ('Число не делиться на 5') ;

    k:=a mod 9;

    If k=0 then writeln ('Число делиться на 9')

    else

    writeln ('Число не делиться на 9') ;

    k:=a mod 10;

    If k=0 then writeln ('Число делиться на 10')

    else

    writeln ('Число не делиться на 10') ;

    k:=a mod 11;

    If k=0 then writeln ('Число делиться на 11')

    else

    writeln ('Число не делиться на 11') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Информатика програмирование составить программу признаки делимости на 3, 5, 9, 10, 11 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачу информатика-паскаль (програмирование) Дано целое положительное четырехзначнгое число. Напишите программу, позволяющую определить сумму двух первых цифр заданного четырехзначного числа. Например 1234 - 3
Ответы (1)
Известны следующие признаки делимости числа N. Д ля делимости на 5 необходимо, чтобы последняя цифра числа была 0 или 5. Описать процедуру проверки признаков делимости. Проверить их для различных значений N. Предмет (Программирование) на Pascal ABC
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Укажите правильное полное имя файла: А) Текстовый файл song. doc Б) d:/информатика/файлы/word. doc В) текстовый файл D:/информатика/файлы/programma Г) / информатика/файлы/photo. doc
Ответы (1)
Пользователь работал с каталогом c:/предметы/физика/текст. Сначала он поднялся на два уровня вверх и после этого спустился сначала в каталог информатика, а потом в каталог оценки. запишите полный путь каталога в котором оказался пользователь.
Ответы (2)