Задать вопрос
18 мая, 12:29

Известны

следующие признаки делимости числа N. Д ля делимости на

5 необходимо, чтобы последняя цифра

числа была 0 или 5.

Описать процедуру

проверки признаков делимости. Проверить

их для различных значений N.

Предмет (Программирование)

на Pascal ABC

+5
Ответы (1)
  1. 18 мая, 13:32
    0
    Var N, lastNum, mod5: integer;

    flag: boolean;

    begin

    readln (N) ;

    lastNum : = N mod 10;

    mod5 : = N mod 5;

    flag : = (lastNum = 5) or (lastNum = 0) ;

    if flag then

    writeln ('Число ', N, ' делится на 5 по признаку делимости')

    else

    writeln ('Число ', N, ' не делится на 5 по признаку делимости') ;

    if (mod5 = 0) then

    writeln ('Число ', N, ' делится на 5 по определению')

    else

    writeln ('Число ', N, ' не делится на 5 по определению') ;

    flag : = flag xor (mod5 = 0) ;

    if flag then

    writeln ('Результаты не совпадают, это не признак делимости!')

    else

    writeln ('Результаты совпадают, это возможно признак делимости')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известны следующие признаки делимости числа N. Д ля делимости на 5 необходимо, чтобы последняя цифра числа была 0 или 5. Описать процедуру ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для делимости числа на 5 необходимо, чтобы последняя цифра числа была 0 или 5. Написать процедуру проверки делимости числа n, вводимого с клавиатуры, на 5. (Паскаль)
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Pascal ABC. Написать процедуру, которая выводит на экран первые 3 элемента из массива, которые не равны друг другу. Или процедуру нахождения 3 максимальных элементов массива, которые не равны друг другу
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)