Задать вопрос
1 сентября, 08:12

Составьте программу (Pascal), которая заполняет массив a (1 ... 10) случайными целыми числами от 1 до 20 и выводит на экран элементы, значения которых больше 5 и меньше 15

+5
Ответы (2)
  1. 1 сентября, 09:12
    0
    Var a:array [1 ... 10] of integer;

    i:integer;

    begin

    for i:=1 to 10 do

    begin

    a[i]:=rndom (20) + 1;

    write (a[i],' ')

    end;

    writeln;

    for i:=1 to 10 do

    if (a[i]>5) and (a[i]<15) then write (a[i],' ')

    end.
  2. 1 сентября, 10:06
    0
    Program program1;

    var

    a:array [1 ... 10] of integer;

    int:integer;

    begin

    for int:=1 to 10 do

    begin

    a[int]:=rndom (20) + 1;

    write (a[int],' ')

    end;

    writeln;

    for int:=1 to 10 do

    if (a[int]>5) and (a[int]<15) then write (a[int],' ')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу (Pascal), которая заполняет массив a (1 ... 10) случайными целыми числами от 1 до 20 и выводит на экран элементы, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)