Задать вопрос
16 мая, 07:44

Составьте программу которая осуществляет ввод в массив с клавиатуры 7 целых чисел и заменяет кратные 4 числа на 1

+4
Ответы (1)
  1. 16 мая, 11:08
    0
    Var a:array[1 ... 7] of integer; i:integer; n1:real;

    begin

    writeln ('Введите 7 целых чисел') ;

    for i:=1 to 7 do

    begin

    repeat

    read (n1) ;

    if (n1round (n1)) then writeln ('Необходимо целое число') ;

    until (n1=round (n1)) ;

    a[i]:=round (n1) ;

    end;

    for i:=1 to 7 do

    begin

    if (a[i] mod 4=0) then a[i]:=1;

    end;

    writeln ('Полученный массив:') ;

    for i:=1 to 7 do

    write (a[i]:5) ;

    writeln ('') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая осуществляет ввод в массив с клавиатуры 7 целых чисел и заменяет кратные 4 числа на 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и: 1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат 2) четные числа заменяет на 2, а от нечетных - отнимает 5 3) числа,
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)