Задать вопрос
19 января, 12:19

Составьте программу, которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от - 15 до 5 и находит количество элементов кратных 3.

+5
Ответы (1)
  1. 19 января, 15:00
    0
    Var

    a:array [1 ... 30] of integer; / / тут можешь регулировать количество чисел

    i, k, n:integer;

    begin

    k:=0;

    writeln ('введите количество чисел от 1 до 30') ;

    read (n) ;

    randomize;

    for i:=1 to n do begin

    a[i]:=random (16) - 5;

    write (a[i]:3) ;

    end;

    writeln () ;

    for i:=1 to n do if (a[i] mod 3=0) and (a[i]0) then k:=k+1;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от - 15 до 5 и находит количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)