Задать вопрос
19 июля, 14:11

Pascal ABC: Найти среднее арифметическое цифр введенного 3-значного числа.

+3
Ответы (1)
  1. 19 июля, 18:08
    0
    Program zadanie;

    label 1;

    var a, i, r, nb:integer; sr: real;

    begin

    1: writeln ('Введите трехзначное число a') ;

    read (a) ;

    r:=0;

    nb:=0;

    while a>0 do

    begin

    i:=a mod 10;

    r:=r+i;

    nb:=nb+1;

    a:=a div 10;

    end;

    if nb=3 then

    begin

    sr:=r/nb;

    writeln ('сумма цифр = ', r) ;

    writeln ('среднее арифметическое = ', sr) ;

    end

    else goto 1;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal ABC: Найти среднее арифметическое цифр введенного 3-значного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.
Ответы (2)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Для числа подсчитывается сумма его цифр. Если результат превышает 9, то для результата снова подсчитывается сумма цифр и так далее, пока результат не станет меньше 10. Выполните расчеты для введенного с клавиатуры не более чем 50-значного числа.
Нет ответа
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)