Задать вопрос
30 сентября, 09:11

Free Pascal. Задать массив, и из массива А в Б переписать сначала все нули, потом отрицательные числа и потом все положительные. Числа рандомные.

+3
Ответы (1)
  1. 30 сентября, 10:53
    0
    Var

    ar, ar2:array[1 ... 10] of integer;

    i:integer;

    begin

    randomize;

    writeln ('First array:') ;

    for i:=1 to 10 do

    begin;

    ar[i]:=random (10) - 3;

    write (ar[i]:4) ;

    if ar[i]=0 then ar2[i]:=0;

    end;

    writeln;

    writeln ('1-st Final array:') ;

    for i:=1 to 10 do

    begin;

    write (ar2[i]:4) ;

    if ar[i]<0 then ar2[i]:=ar[i];

    end;

    writeln;

    writeln ('2-st Final array:') ;

    for i:=1 to 10 do

    begin;

    write (ar2[i]:4) ;

    if ar[i]>0 then ar2[i]:=ar[i];

    end;

    writeln;

    writeln ('3-st Final array:') ;

    for i:=1 to 10 do

    write (ar2[i]:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Free Pascal. Задать массив, и из массива А в Б переписать сначала все нули, потом отрицательные числа и потом все положительные. Числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
H. Работа с несколькими массивами Дан массив a, состоящий из n целых чисел. Ваша задача - переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.
Ответы (1)
Напишите программу на языке Pascal. Элементы массива А, удовлетворяющие условию А (i) >5.5, переписать в массив В, а элементы, удовлетворяющие условию А (i)
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)