Задать вопрос
18 января, 15:30

Написать программу на языке Паскаль:

На место положительных элементов массива (a1, a2, ... an) записать единицы и сосчитать их количество. для отрицательных элементов массива определить их сумму.

исходные данные:

n=12

a = [-8, 10, 11, - 30, 21, 22, - 5, 10, - 10, - 12, 1, 5]

+3
Ответы (1)
  1. 18 января, 17:06
    0
    Program mas1;

    var a:array[1 ... 100] of integer;

    k, sum, n, i:integer;

    Begin randomize;

    k:=0;

    sum:=0;

    writeln ('Введите размерность массива', n) ;

    readln (n) ;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n do

    begin if a[i]>0 then

    begin a[i]:=1;

    k:=k+1;

    end;

    write (' ', a[i]) ;

    if a[i]<0 then

    begin sum:=sum+a[i];

    end;

    end;

    writeln (' sum=', sum,' k=', k) ;

    readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке Паскаль: На место положительных элементов массива (a1, a2, ... an) записать единицы и сосчитать их количество. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Решить задачу на языке Pascal. Дан массив LL, содержащий 12 элементов вещественного типа - положительных, отрицательных и равных нулю. Сосчитать количество ненулевых элементов массива и сформировать из них новый массив.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)