Задать вопрос
15 октября, 13:18

Даны 4 точки A1 (x1, y1), A2 (x2, y2), A3 (x3, y3), A4 (x4, y4). Определить, будут ли они вершинами параллелограмма. Нужно решить на Pascal, но без использования мудренных команда.

+5
Ответы (1)
  1. 15 октября, 14:29
    0
    Var

    x1, x2, x3, x4, y1, y2, y3, y4: real;

    function VectorLength (x1, y1, x2, y2: real) : real;

    begin

    VectorLength : = sqrt (sqr (x1 - x2) + sqr (y1 - y2)) ;

    end;

    function VectorSlope (x1, y1, x2, y2: real) : real;

    begin

    VectorSlope : = (y1 - y2) / (x1 - x2) ;

    end;

    begin

    readln (x1, y1) ;

    readln (x2, y2) ;

    readln (x3, y3) ;

    readln (x4, y4) ;

    if (VectorLength (x1, y1, x2, y2) = VectorLength (x4, y4, x3, y3))

    and (VectorSlope (x1, y1, x2, y2) = VectorSlope (x4, y4, x3, y3)) then

    writeln ('Yes')

    else writeln ('No') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 4 точки A1 (x1, y1), A2 (x2, y2), A3 (x3, y3), A4 (x4, y4). Определить, будут ли они вершинами параллелограмма. Нужно решить на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как перевести 7 в 8 за 4 шага. 1 ая команда + 5; 2 ая команда: 2; И ещё Как перевести 4 в 55 за 5 шагов. 1 ая команда * 5; 2 ая команда - 3;
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Пользователь работал с каталогом Команда. Сначала он поднялся на один уровень вверх, затем спустился на один уровень вниз, потом ещё раз спустился на один уровень вниз.
Ответы (1)