Задать вопрос
19 февраля, 12:56

Проггамма паскаль Найти среднее арифметическое не равных нулю элементов масивные X (n, m) и подсчитать количество элементов с неподлжительными значениями

+2
Ответы (1)
  1. 19 февраля, 14:25
    0
    Program abc;

    Const

    n=3;

    m=3;

    Var a:array[1 ... n, 1 ... m] of integer;

    b, y, i, j, sum:integer;

    srd:real;

    Begin

    Writeln ('Введите числа массива: ') ;

    For i:=1 to n do

    For j:=1 to m do

    Begin

    Write ('a[', i,',', j,'] = ') ;

    Readln (a[i, j]) ;

    if a[i, j]>0 then

    begin

    sum:=sum+a[i, j];

    inc (b) ;

    end

    else

    If a[i, j]<0 then

    Inc (y) ;

    End;

    If sum>0 then

    begin

    srd:=sum/b;

    Writeln ('Среднее = ', srd) ;

    end

    else

    Writeln ('Нет положительных членов массива') ;

    If y>0 then

    begin

    Writeln ('Количество отрицательных элементов = ', y) ;

    end

    else

    Writeln ('Нет отрицательных членов массива') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Проггамма паскаль Найти среднее арифметическое не равных нулю элементов масивные X (n, m) и подсчитать количество элементов с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Помогите написать на паскале (Д) Заполнить массив из пятнадцати элементов случайным образом: а) вещественными значениями, лежащими в диапазоне от 0 до 1; б) вещественными значениями х (22 х < 23) ; в) вещественными значениями х (0 х < 10) ;
Ответы (1)
Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива.
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)