Задать вопрос
6 ноября, 10:43

Дано натуральное число: а) найти произведение его цифр; б) верно ли, что в данном числе нет данной цифры А (А вводитмя с клавиатуры)

+1
Ответы (1)
  1. 6 ноября, 14:32
    0
    Var n, k, i, a:integer;

    begin;

    k:=1;

    i:=0;

    readln (n) ;

    readln (a) ;

    while n>=1 do

    begin;

    if (n mod 10) = a then

    i:=1;

    k:=k * (n mod 10) ;

    n:=n div 10;

    end;

    writeln ('Произведение:', k) ;

    if i=1 then writeln ('Да') else writeln ('Нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число: а) найти произведение его цифр; б) верно ли, что в данном числе нет данной цифры А (А вводитмя с клавиатуры) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. а) найти произведение цифр числа. б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры). 2.
Ответы (1)
Дано натуральное число: * найти произведение его цифр * верно ли, что в данном числе нет данной цифры А, А ввод. с клавиатуры В паскале
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)