Задать вопрос
8 сентября, 12:44

Составить программу в Паскале.

Вводится строка. Удвоить каждый ее символ.

+2
Ответы (1)
  1. 8 сентября, 13:03
    0
    Это делается очень просто:

    var s, s1:string; i:integer;

    begin

    writeln ('Введите строку:') ;

    readln (s) ;

    s1:='';

    for i:=1 to length (s) do s1:=s1+s[i]+s[i];

    s:=s1;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в Паскале. Вводится строка. Удвоить каждый ее символ. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Укажите алгоритмы устранения следующих ошибок: 1) Установить курсор на место вставки. 2) Нажать клавишу с нужным символом. Что это Лишний символ, пропущенный символ, неверный символ? 1) Установить курсор за ошибочным символом.
Ответы (1)
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки.
Ответы (1)
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки. "выбрать из нее символы кратные 4 и напечатать их (т. е.
Ответы (1)