Задать вопрос
20 декабря, 21:58

Сформировать массив из 10 чисел по следующим правилам: первый элемент равен 3, второй 4, а каждый следующий равен среднему арифметическому двух предыдущих написать задачку)

+2
Ответы (1)
  1. 20 декабря, 22:13
    0
    На Паскале

    var

    a:array[1 ... 10] of real;

    i:integer;

    begin

    a[1]:=3;

    a[2]:=4;

    for i:=3 to 10 do

    a[i]: = (a[i-2]+a[i-1]) / 2;

    for i:=1 to 10 do

    write (a[i],' ') ;

    end.

    На C++

    #include

    void main ()

    {

    float a[10] = { 3,4 };

    for (int i = 2; i < 10; i++)

    a[i] = (a[i - 2] + a[i - 1]) / 2;

    for (int i = 0; i < 10; i++)

    std::cout << a[i] << '/t';

    system ("pause") ;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать массив из 10 чисел по следующим правилам: первый элемент равен 3, второй 4, а каждый следующий равен среднему арифметическому ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
4. Из элементов массива A сформировать массив A той же размерности по правилам: Если номер четный, то B[i]:=i*, если нечетный, то B[i]:=-A[i]. 5. Сформировать массив а с помощью датчика случайных чисел целыми числами из интервала [-15,70]. 6.
Ответы (1)
Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. получите новый масив, каждый элемент которого равен среднему арифметическому соответствующего элемента исходного массива и введенного с клавиатуры числа А.
Ответы (1)
Дан массив на 9 элементов. Первый элемент равен квадрату текущего индекса, увеличенному на 5. Второй элемент равен целой части квадратного корня из предыдущего элемента. Третий элемент равен сумме двух предыдущих элементов
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)