Задать вопрос
13 ноября, 08:19

Помогите составить программу в Паскале.

вместимость бочки n литров, вместимость ведра k литров, сколько ведер надо принести чтобы наполнить бочку, считая что бочка наполнена даже если последние ведро выльется через край

+5
Ответы (1)
  1. 13 ноября, 08:53
    0
    Var x, n, k:integer;

    begin

    writeln ('Введите вместимость бочки - ') ;

    read (n) ;

    writeln ('Введите вместимость ведра - ') ;

    read (k) ;

    x: = n div k + 1;

    writeln ('Количество ведер, необходимое для заполнения бочки = ', x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу в Паскале. вместимость бочки n литров, вместимость ведра k литров, сколько ведер надо принести чтобы наполнить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Есть три пустых ведра: 8 литров, 5 литров и 3 литра. 8-литровое ведро наполнено водой, два других пустые. Как напоить двух лошадей, дав каждой по 4 литра воды. Команды; налить в ведро, вылить из ведра, перелить из одного ведра в другое.
Ответы (1)
Рядом с колодцем стоят два ведра - на 5 и 12 литров. Мальчику нужно с их помощью отмерить ровно 9 литров воды. Опишите, какие из указанных ниже действий и в какой последовательности должен производить мальчик.
Ответы (1)
3 бочки с водой - 12 литров, 7 литров, 5 литров. Двенадцати литровая бочка полностью заполнена. Надо переливать так чтобы в двенадцати литровой и в семи литровой окозалось по 6 литров.
Ответы (1)
Разлей на 3 равные частей 24-ведёрную бочку воды, используя для этого три других пустых бочонка объёмом 13 вёдер, 11 вёдер и 5 вёдер.
Ответы (1)
Ученики третьего класса собирали яблоки, первый ученик собрал x вёдер, второй собрал y вёдер, третий собрал n вёдер яблок. Сколько вёдер яблок собрали ученики?
Ответы (1)