Задать вопрос
19 марта, 13:50

На каждом следующем дне рождения Винни Пух съедает столько же меда, что и на двух предыдущих. На двух первых днях рождения у Пяточка и у Кролика он съел по 100 г меда. Написать программу, определяющую, сколько килограммов меда съест Винни Пух на - ом дне рождения.

Формат входных данных

Во входном файле задано единственное число (1 до 40).

Формат выходных данных

Выведите, сколько килограммов меда съест Винни Пух на этот день рождения с точностью до одного знака после десятичной точки.

+1
Ответы (1)
  1. 19 марта, 14:00
    0
    Var

    n, a, b, c, c2, i:integer;

    Begin

    Write ('Введите число ') ;

    Readln (n) ;

    a:=100;

    b:=100;

    for i: = 1 to n do Begin

    c:=a+b; a:=b; b:=c;

    End;

    c2:=c div 1000;

    write (c2,'.') ;

    c:=c div 100 mod 10;

    write (c,' кг съел Винни') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На каждом следующем дне рождения Винни Пух съедает столько же меда, что и на двух предыдущих. На двух первых днях рождения у Пяточка и у ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На каждом следующем дне рождении Винни съедает столько же меда, сколько съел на двух предыдущих вместе. На двух первых днях рождения у пяточка и кролика он съел по 0,1 кг меда. Определить, сколько кг меда он съест на десятом дне рождении.
Ответы (1)
Составьте задачу в Паскаль с помощью while. На каждом следующем дне рождения Винни Пух съедает столько же меда, сколько съел на двух предыдущих вместе. На двух первых днях рождения у Пятачка и Кролика он съел по 100 г меда.
Ответы (1)
Составьте блок-схему для решения следующей задачи. На двух первых днях рождения у Пятачка и Кролика Винни-Пух съел всего 100 г пищи.
Ответы (1)
Написать программу в Паскале. По заданному числу N определите знак числа. Формат входных данных: Во входном файле input.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)