Задать вопрос
6 октября, 01:31

Составьте задачу в Паскаль с помощью while. На каждом следующем дне рождения Винни Пух съедает столько же меда, сколько съел на двух предыдущих вместе. На двух первых днях рождения у Пятачка и Кролика он съел по 100 г меда. Определите, сколько килограммов меда он съест на десятом дне рождения.

+3
Ответы (1)
  1. 6 октября, 02:37
    0
    Числа Фибоначчи (вместо 1 только 100) !

    var m1, m2, s, i:integer;

    begin

    m1:=100; m2:=100;

    for i:=3 to 10 do

    begin

    s:=m1+m2;

    m1:=m2;

    m2:=s;

    end;

    writeln (s) ;

    end.

    Результат:

    5500
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте задачу в Паскаль с помощью while. На каждом следующем дне рождения Винни Пух съедает столько же меда, сколько съел на двух ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На каждом следующем дне рождения Винни Пух съедает столько же меда, что и на двух предыдущих. На двух первых днях рождения у Пяточка и у Кролика он съел по 100 г меда.
Ответы (1)
На каждом следующем дне рождении Винни съедает столько же меда, сколько съел на двух предыдущих вместе. На двух первых днях рождения у пяточка и кролика он съел по 0,1 кг меда. Определить, сколько кг меда он съест на десятом дне рождении.
Ответы (1)
Составьте блок-схему для решения следующей задачи. На двух первых днях рождения у Пятачка и Кролика Винни-Пух съел всего 100 г пищи.
Ответы (1)
Паскаль: Пух на дне рождении кролика впервый час съел 100 грамм меда. А за тем каждый час съедал на 50 грамм больше. Сколько меда он съест за t часов?
Ответы (2)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)