Задать вопрос
17 августа, 16:23

Составьте программу вычисления в массиве В, состоящем из восьми элементов, суммы отрицательных элементов.

паскаль

+1
Ответы (1)
  1. 17 августа, 18:51
    0
    var a, b, sum:integer;

    arr : array [0 ... 7] of integer;

    begin

    sum:=0;

    write ('введите элементы массива : ') ;

    for a:=0 to 7 do begin

    read (b) ;

    arr[a]:=b;

    end;

    for a:=0 to 7 do begin

    if arr[a]<0 then sum:=sum+arr[a];

    end;

    writeln ('сумма отрицательных элементов массива = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления в массиве В, состоящем из восьми элементов, суммы отрицательных элементов. паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) составьте программу вычисления в массиве А, содержащего N элементов, произведения положительных чисел. Pascal 2) составьте программу вычисления суммы элементов от первого отрицательного и до конца. Pascal
Ответы (1)
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)