Задать вопрос
15 сентября, 16:25

Дается последовательность из N чисел. Найдите максимальное произведение среди всех пар этих чисел.

Первая строка входного файла содержит целое число N (1<=N<=1000). В следующей строке задаются N целых чисел, каждое из которых по модулю меньше или равно 1000.

+2
Ответы (1)
  1. 15 сентября, 16:32
    0
    Var ar:array of integer;

    max, i, n, j:integer;

    begin;

    max:=-2147483648; / / нижняя граница integer

    writeln ('Введите размерность массива:') ; / / массив всегда приятнее

    readln (n) ;

    setlength (ar, n+1) ; / / задали размерность динамического массива

    for i:=1 to n do

    begin;

    write ('Введите ', i, ' элемент массива:') ;

    readln (ar[i]) ;

    end;

    for i:=1 to n do

    for j:=1 to n do

    if max
    writeln ('Result:', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дается последовательность из N чисел. Найдите максимальное произведение среди всех пар этих чисел. Первая строка входного файла содержит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.
Ответы (1)
Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)
Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 100000).
Ответы (1)