Задать вопрос
23 июня, 14:57

Написать программу в Turbo pascal

Найти 2 максимума из любой последовательности чисел

+3
Ответы (1)
  1. 23 июня, 18:29
    0
    Var ar:array[1 ... 30] of integer;

    i, max, max2, maxp, maxi:integer;

    begin;

    randomize;

    writeln ('Array') ;

    for i:=1 to 30 do

    begin;

    ar[i]:=random (1,100) ;

    write (ar[i]:4) ;

    end;

    for i:=1 to 30 do

    if max
    begin;

    maxp:=max;

    max:=ar[i];

    maxi:=i;

    end;

    ar[maxi]:=maxp;

    for i:=1 to 30 do

    if max2
    writeln;

    writeln ('Max1:', max) ;

    writeln ('Max2:', max2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Turbo pascal Найти 2 максимума из любой последовательности чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Помогите написать программу в turbo Pascal. Напишите программу Генератором случайных чисел генерируется последовательность 50-ти случайных чисел из диапазона [-10; 20].
Ответы (1)