Задать вопрос
28 мая, 16:14

Помогите написать программу в turbo Pascal. Напишите программу Генератором случайных чисел генерируется последовательность 50-ти случайных чисел из диапазона [-10; 20]. Вычислить сумму положительных элементов последовательности, порядковые номера которых нечетны.

+2
Ответы (1)
  1. 28 мая, 17:57
    0
    Var a : array[1 ... 50] of integer;

    sum, i : integer;

    begin

    randomize;

    for i : = 1 to 50 do begin

    a[i] : = random (31) - 10;

    if (a[i] > 0) and (i mod 2 0) then

    sum : = sum + a[i];

    end;

    write (sum)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в turbo Pascal. Напишите программу Генератором случайных чисел генерируется последовательность 50-ти случайных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Ответьте в кумире или Паскале 1. Найти среднее арифметическое значений всех элементов массива, состоящего их случайных положительных чисел. 2. В массиве из 15-ти целых случайных чисел из диапазона [-30; 70] найти минимальный положительный элемент. 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)