Задать вопрос
7 декабря, 00:01

Дана последовательность действительных чисел а1, а2, ..., аn. Выяснить, быдет ли она возрастающей. Написать прогу. Паскаль

+2
Ответы (1)
  1. 7 декабря, 02:13
    0
    Const n=10;

    var a:array[1 ... n] of real;

    i:integer;

    b:boolean;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=10*random;

    write (a[i]:5:1) ;

    end;

    writeln;

    b:=true;

    for i:=1 to n-1 do

    if a[i]>=a[i+1] then b:=false;

    if b

    then writeln ('Последовательность возрастающая')

    else writeln ('Последовательность не возрастающая') ;

    end.

    Пример:

    5.3 1.4 0.2 6.1 5.7 0.8 3.4 6.2 6.2 8.4

    Последовательность не возрастающая
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность действительных чисел а1, а2, ..., аn. Выяснить, быдет ли она возрастающей. Написать прогу. Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана последовательность действительных чисел. Выяснить, будет ли она возрастающей (Паскаль) нужен листинг
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дана последовательность действительных чисел. Выяснить, будет ли она возрастающей Turbo Pascal
Ответы (1)
1. Дан массив натуральных чисел. Найти сумму элементов кратных данному К. 2. В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов. 3. дана последовательность целых чисел а1, а2, ... аn.
Ответы (1)
Дана последовательность целых чисел. Прищнак окончания ввода - число 0 (элементом последовательности не считается). В последовательности как минимум одно число. Написать программу, определяющую, является ли последовательность чисел возрастающей.
Ответы (1)