Задать вопрос
6 апреля, 17:06

Помогите написать программу на паскале: даны 2 текстовых файла. определить в каком файле больше запятых

+4
Ответы (1)
  1. 6 апреля, 17:56
    0
    Var f1:text;

    f2:text;

    s1, s2:string;

    k1, k2:integer;

    begin;

    assign (f1,'f1. txt') ;

    reset (f1) ;

    while not Eof (f1) do

    read (f1, s1) ;

    close (f1) ;

    assign (f2,'f2. txt') ;

    reset (f2) ;

    while not Eof (f2) do

    read (f2, s2) ;

    close (f2) ;

    while pos (',', s1) 0 do

    begin;

    delete (s1, pos (',', s1),1) ;

    inc (k1) ;

    end;

    while pos (',', s2) 0 do

    begin;

    delete (s2, pos (',', s2),1) ;

    inc (k2) ;

    end;

    if k1>k2 then writeln ('В первом') ;

    if k2>k1 then writeln ('Во втором') ;

    if k2=k1 then writeln ('Равно') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на паскале: даны 2 текстовых файла. определить в каком файле больше запятых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выберите возможности текстового редактора Выберите один или несколько ответов: a. печать текстовых документов b. создание текстовых документов c. просмотр текстовых документов d. редактирование текстовых документов
Ответы (1)
Расширение имени файла, как правило, характеризует: а) время создания файла б) объем файла б) место, занимаемое файлом на диске г) тип информации, содержащийся в файле д) место создания файла
Ответы (1)
Даны два текстовых файла f и g. Определить, совпадают ли компоненты файла f с компонентами файла g. Если нет, то получить номер первой строки и первого символа в этой строке, в которых файлы f и g отличаются между собой.
Ответы (1)
Запишите шаблон для поиска файла имена которых: 1) name, а расширение имени файла произвольно 2) начинаются с буквы t и казанчиваются буквой k 3) произвольные, а расширение имени файла имеет лишь один символ 4) начитаются с буквы n и имеют в
Ответы (1)
Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в след за которыми в файле f идёт буква а
Ответы (1)