Задать вопрос
11 мая, 09:08

Составить программу для решения задачи. Найти сумму всех положительных элементов массива, состоящего из семи элементов.

+3
Ответы (1)
  1. 11 мая, 09:14
    0
    var

    i, s:integer;

    a: array [ 1 ... 7 ] of integer;

    begin

    for i:=1 to 7 do

    begin

    writeln ('Введите эл. массива A[', i, ']') ;

    readln (A[i]) ;

    end;

    for i:=1 to 7 do

    if a[i]>0 then s:=s+a[i];

    writeln ('Сумма всех положительных элементов массива: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для решения задачи. Найти сумму всех положительных элементов массива, состоящего из семи элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)