Задать вопрос
27 июля, 00:20

Составить программу, которая формирует массив из 5 случайных чисел от - 10 до 15.

а) найти элементы равные 1.

б) найти индекс нечетных элементов.

в) Найти количество положительных элементов.

+3
Ответы (1)
  1. 27 июля, 00:41
    0
    Const n=5;

    var a : array[1 ... n] of integer;

    k, i : integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (26) - 10;

    write (a[i],' ') ;

    end;

    writeln;

    writeln ('элементы равные 1 имеют номера:') ;

    for i:=1 to n do if a[i]=1 then write (i:3) ;

    writeln;

    writeln ('индексы нечетных элементов:') ;

    for i:=1 to n do if a[i] mod 20 then write (i:3) ;

    writeln;

    k:=0;

    for i:=1 to n do if a[i]>0 then k:=k+1;

    writeln ('количество положительных элементов=', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая формирует массив из 5 случайных чисел от - 10 до 15. а) найти элементы равные 1. б) найти индекс нечетных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)