Задать вопрос
26 февраля, 19:16

Если хватит ума

Паскаль. Определить наибольшее значение произведения А[i]*A[i-1]

+2
Ответы (2)
  1. 26 февраля, 19:32
    0
    Var

    a:array[0 ... 5] of longint;

    b, c, d, e, i:longint;

    begin

    b:=-maxlongint;

    for i:=1 to 5 do read (a[i]) ;

    for i:=1 to 5 do if a[i]*a[i-1]>b then b:=a[i]*a[i-1];

    writeln (b) ;

    end.
  2. 26 февраля, 20:59
    0
    Var ar:array[1 ... 10] of integer;

    max, i:integer;

    begin;

    randomize;

    max:=-1;

    writeln ('Array:') ;

    for i:=1 to 10 do

    begin;

    ar[i]:=random (100) ;

    write (ar[i]:4) ;

    end;

    writeln;

    writeln ('Combinations:') ;

    for i:=2 to 10 do

    begin;

    write (ar[i]*ar[i-1]:6) ;

    if ar[i]*ar[i-1]>max then max:=ar[i]*ar[i-1];

    end;

    writeln;

    writeln ('Result:', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Если хватит ума Паскаль. Определить наибольшее значение произведения А[i]*A[i-1] ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
На каком языке программирования можно писать на егэ? и во всех ли заданиях на этом (этих) языка я слышал что можно бейсик паскаль си питон Но в школе проходят не паскаль а Паскаль АБС можно ли по этому правилу сдавать егэ на С + + или С#?
Ответы (1)
6) Ребята в классе из 30 человек изучают языки программирования, и каждый знает зотя бы один язык. Паскаль изучили 20 человек, Python 15 человек, C + + 10 человек. Паскаль и Python знают 5 человек, Паскаль и C + + 8 человек, Python и С + + 5 человек.
Ответы (1)
Паскаль, составить программу! 1. Дано слово, определить есть ли в нем буква а! Паскаль! (Ответить на вопрос да или нет) 2. Дано предложение, определить длину последнего слова.
Ответы (1)