Задать вопрос
11 ноября, 07:11

Составить программу на Turbo paskal:

Вычислить a в степени n (n>0), где а-вещественное число, которое необходимо возвести в целую положительную степень n.

+1
Ответы (1)
  1. 11 ноября, 10:01
    0
    Var a:real;

    i, n, p:integer;

    Begin

    write ('n = ') ;

    readln (n) ;

    write ('a = ') ;

    readln (a) ;

    p:=1;

    for i:=1 to n do

    p:=p*a;

    writeln ('a^n = ', p:8:3) ;

    readln

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на Turbo paskal: Вычислить a в степени n (n>0), где а-вещественное число, которое необходимо возвести в целую ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
Дано вещественное число R и массив размера N. Найти элемент массива который наиболее близок к данному числу. Написать программу в Paskal, Lazarus.
Ответы (1)
Число 712 возвести в двоичную систему счисления и обратно число 712 возвести в восьмеричную систему счисления и обратно число 712 возвести в шестнадцатеричную систему счисления
Ответы (1)
Напишите программу на языке Паскаль. Ввести 2-а числа первое число-степень втрое-любое вещественное число вычислить степень с натуральным показателем n для любого вещественного числа a
Ответы (1)
Дано вещественное число с двумя цифрами в целой части и одной цифрой в дробной части. Получить вещественное число, запись которого являлась бы зеркальным отображением исходного числа (например, 36.2 и 2.63).
Ответы (1)