Задать вопрос
13 ноября, 23:52

Дано вещественное число R и массив размера N. Найти элемент массива который наиболее близок к данному числу. Написать программу в Paskal, Lazarus.

+3
Ответы (1)
  1. 14 ноября, 01:15
    0
    Program nearone;

    var R, i, x, N:integer; a:array[1 ... 10] of integer;

    begin

    for i:=1 to 10 do

    begin

    a[i]:=random (50) ;

    writeln (a[i]) ;

    end;

    write ('Число R - >') ;

    readln (R) ;

    x:=abs (a[1]-R) ;

    N:=1;

    for i:=2 to 10 do

    if x > abs (a[i]-R) then

    begin

    x:=abs (a[i]-R) ;

    N:=i;

    end;

    writeln ('Ближайшее число - ', a[N]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано вещественное число R и массив размера N. Найти элемент массива который наиболее близок к данному числу. Написать программу в Paskal, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано вещественное число R и массив размера N. Найти элемент массива который наиболее близок к данному числу
Ответы (1)
Дан одновременный массив, состоящий из 10 эллементов. Пользователь вводит элементы массива. Ввести массив на экран в строку. Найти минимальный элемент массива.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)